오픈소스 프로그램인 아톰 에디터의 경우 업데이트 후 패키지와 호환되지 않아 에러를 일으키는 경우가 있습니다. 이런 경우 에러를 빠르게 픽스해주면 좋겠지만 그렇지 못합니다.

그래서 패키지를 다운그레이 시켜서 이용해야 할때가 있습니다. 하지만 아톰 에디터 패키지 메뉴에서 지원 하지 않아 터미널로 접속하여 apm 명령으로 수동 설치해줘야 합니다.

apm은 atom package manager 를 뜻 합니다.




터미널을 실행하여 apm이 설치 되어 있는지 확인 합니다.


apm help install

 



not found command 라고 뜬다면 아톰에서 Atom > Install Shell Commands 메뉴를 선택해서 apm을 설치 해줍니다.

설치할때 특별한 반응은 없습니다.






다시 터미널로 돌아와서 apm이 설치되었는지 확인 합니다.


apm help install

 



정상적으로 설치가 되었다면 아래와 같이 옵션에 대한 정보가 보입니다.





저의 경우 remote-ftp 패키지 1.1.4 버전이 아톰 1.18.0과 문제를 일으켰었습니다.
따라서 remote-ftp 패키지를 1.1.3 버전으로 설치 해주었습니다.

apm install remote-ftp@1.1.4

 

Installing 라는 메시지가 뜨면 제대로 설치되고 있는것 입니다. 
설치가 완료되면 아톰에서 원하는 버전으로 정상 설치되었는지 확인 합니다.





copyright ⓒ 2017 워크식스









+ Recent posts